Tagged

MacOS

A collection of 9 posts

Windows

Macbook 只安装 Windows 10 系统

我们知道,通过 MacOS 自带的“启动转换助理”可以制作Windows系统安装U盘,一般我们会在 MacOS 的基础上额外增加一个 Windows 系统,两个系统共享硬盘。 身边有亲戚需要在 Macbook 上只安装 Windows 10 系统,遂尝试。 其实安装方法于常规安装 Windows 的流程一致,通过“启动转换助理”制作Windows系统安装U盘以后,关闭电脑。按住 Command + R 不松手,同时按一下电源按钮开机,直到出现 Mac 的系统恢复界面。 使用界面中的磁盘管理功能,将 Mac 的系统盘抹掉。一般而言,抹掉之后我们会点击界面中的恢复 macOS,但我们不需要 mac 系统,所以直接选择关机。 插入制作好的 Windows 系统安装盘,在开机之前按住 option

Rime

macOS rime squirrel 配置

最近开发任务的压力蛮大,实在受不了 macOS 默认输入法。终端 brew cask install squirrel 把中州韻鼠鬚管跑起来吧,可是这东西需要编辑配置文件,有点小麻烦。 默认中文显示 之前在 elementary OS 安装中州韻输入法 中记录了配置内容,再重贴一次。 正常使用组合键 Ctrl+ ' 可显示选单,选择输出简体中文即可。 但要默认直接输出简体中文就要在配置目录中创建一个自定义的配置文件: $ code ~/Library/Rime/luna_pinyin.custom.yaml # luna_pinyin.custom.yaml patch: switches: # 注意縮進 - name: ascii_mode reset: 0 # reset 0 的作用是當從其他輸入方案切換到本方案時, states: [ 中文,

MacOS

MacOS 读写挂载 NTFS 移动硬盘

MacOS 系统默认只能以只读模式挂载 NTFS 分区,有一些支持读写挂载的第三方应用都需要额外付钱购买。熟悉 Linux 系统的用户对 ntfs-3g 都不会陌生,它主要用来在 linux 系统下挂载 ntfs 分区。发现在 MacOS 上也可以使用,尝试了一下,发现效果不错。 解决依赖 在 MacOS 上安装 ntfs-3g 需要先安装 osxfuse,直接去官方仓库下载最新的 dmg 安装即可。 安装 ntfs-3g ntfs-3g 在 homebrew/core 中,直接安装: $ brew install ntfs-3g 使用 使用之前需要创建一个挂载点,可以创建在家目录,例如: ~ $ mkdir ntfs 插入移动硬盘,执行 diskutil

MacOS

Homebrew 简易用法

Homebrew 是 MacOS 下的一款包管理,可以用来安装苹果官方没有提供的应用。 Homebrew 将应用安装到 Cellar 并在 /usr/local 创建相应的符号链接,执行 brew ls 查看已安装应用的软链接指向情况。 formula - 配方,是 Homebrew 的基本单元,它是用 ruby 写成的配置文件。执行 brew create <URL> 即可创建 <URL> 是配方指向的源码压缩包。 软件包依其 formulae 定义而安装,执行 brew edit xxx 修改一个软件包的配方文件。 安装 homebrew /usr/bin/ruby -e

Tinc

macOS 安装 tinc

使用 brew 安装 tinc 时,程序默认安装在 /usr/local/Cellar/ 目录,tincd 二进制文件被软连接到 /usr/local/sbin。所以应该将这个目录添加到系统执行路径,编辑 /etc/paths 添加此路径即可。 安装 tuntap MacOS 创建虚拟网卡依赖 tuntap,需要使用 brew 进行安装。目前,tuntap 已经从原来的 homebrew/core 仓库迁移至 homebrew/cask,执行以下命令安装: $ brew cask install tuntap 配置 tinc tincd 默认从 /usr/local/etc/tinc 目录读取配置,

OSS

s3fs-fuse 把 s3-like 对象存储挂载到本地

s3fs-fuse 是一个采用 c++ 开发的开源应用,它的作用是可以将 AWS S3 以及兼容 S3 API 的第三方对象存储像普通文件系统一样挂载到本地计算机,由于这种功能通过 FUSE 实现,因此只能在 Linux 和 MacOS 上使用。 安装 包管理器安装 Debian 9 和 Ubuntu 16.04 及以上版本: $ sudo apt install s3fs 发行版软件仓库中可能提供的不是最新版本 编译安装 如果希望使用最新版本,可以自己编译。 安装编译工具和依赖 $ sudo apt-get install automake autotools-dev fuse g++ git libcurl4-openssl-dev libfuse-dev libssl-dev libxml2-dev make